Passer au contenu principal
Maintenez vos activités pendant le COVID-19En savoir plus
Contactez-nous
Numéros de téléphone et heures
Centre d’aide

Explorez nos ressources d’aide en ligne

BlogAide

Managed WordPress Aide

Nous avons fait de notre mieux afin de traduire cette page pour vous. La page en anglais est également disponible.

Retrait des anciennes versions de PHP

Avertissement: Tout au long du mois de juillet 2022, nous supprimerons toutes les versions de fin de vie (EOL) de PHP sur notre plate-forme d'hébergement Managed WordPress.

PHP est le langage de programmation sur lequel repose le code WordPress. Ce langage fonctionne sur le serveur et il est important de le maintenir à jour pour la sécurité et la fonctionnalité de votre site WordPress.

Sélectionnez une question pour voir sa réponse:

Pourquoi cela se produit-il?

Les versions en fin de vie (EOL) ne sont plus prises en charge pour les mises à jour de sécurité, ce qui peut rendre votre site WordPress vulnérable. La mise à jour vers la version PHP actuelle peut également améliorer les performances et la stabilité de la plupart des sites.

Pour nous préparer à cela, nous nous préparons à retirer les versions PHP suivantes:

  • 5.6
  • 7.0, 7.1, 7.2, 7.3

Comment savoir quelle version de PHP j'utilise?

Votre version PHP est visible à plusieurs endroits:

  • Tableau de bord d' hébergement Managed WordPress: Sous Paramètres > Site de production > Version PHP . Vous pouvez également mettre à jour votre version PHP ici.
  • Tableau de bord WordPress: Sur la page d'accueil, un message de l'administrateur affiche Mise à jour PHP requise . Suivez le lien pour mettre à jour votre version PHP.
  • Script d'informations PHP: Vous pouvez créer un fichier d'informations PHP et le placer dans votre répertoire public_html. Cela affichera les informations de votre version PHP lorsque le fichier sera chargé dans votre navigateur.

Que recommandez-vous que je fasse?

Si votre site fonctionne sur une version EOL de PHP, nous vous recommandons d'être proactif et de mettre à jour votre site.

Tout d'abord, vous devez mettre à jour vos plug-ins et votre thème actif . Il s'agit de la cause la plus probable de problèmes lors de la mise à jour de la version PHP de votre site WordPress. Vous devez également profiter de cette occasion pour consulter la documentation du développeur pour vos plug-ins et votre thème pour voir s'il y a des problèmes à prendre en compte lors de la mise à jour de la version PHP.

Nos plans Managed WordPress Deluxe, Ultimate et E-commerce incluent un site intermédiaire en un clic sur lequel vous pouvez tester votre site sur la dernière version de PHP. C’est un endroit idéal pour dépanner et résoudre les problèmes que vous pourriez rencontrer sans affecter votre site en ligne. Une fois que vous avez effectué la mise à jour et corrigé les problèmes dans votre site intermédiaire, vous pouvez appliquer les modifications à votre site en ligne.

Remarque: si votre site utilise un plan Managed WordPress de base, vous devrez passer à un plan Deluxe, Ultimate ou E-commerce pour accéder à l'environnement de test. ( Voici comment mettre à niveau )

En fonction de la version PHP EOL utilisée sur votre site, il se peut que vous n'ayez pas besoin de beaucoup de modifications pour que votre site fonctionne correctement. Plus la version est ancienne, plus la préparation de votre site au changement sera importante.

Si votre site fonctionne avec la version 5.6 de PHP, vous devez consulter les fonctionnalités qui sont obsolètes dans PHP 7.0.x sur PHP.net. Vous devrez peut-être faire intervenir votre développeur ou administrateur WordPress pour vous assurer que votre site fonctionnera correctement après le changement de version de PHP.

Si votre site fonctionne sous PHP 7.0 - 7.3, vous pouvez trouver des informations sur la migration vers une version plus récente dans les annexes sur PHP.net.

Si vous n'avez pas de développeur ou d'administrateur WordPress pour vous aider avec votre site, notre service payant WordPress Premium Support peut vous aider.

Comment changer la version PHP?

Dans la section Paramètres de votre tableau de bord d'hébergement Managed WordPress, vous pouvez modifier la version PHP .

Que se passe-t-il si je ne fais rien?

Si votre site Web utilise actuellement une version PHP EOL et que vous n'agissez pas, vous constaterez peut-être que certains aspects de votre site Web ne fonctionneront pas s'ils dépendent du code obsolète dans ces anciennes versions. Vous devriez consulter votre développeur Web ou votre administrateur WordPress en cas de doute.

Avec le retrait des versions EOL de PHP, toute personne qui utilise encore une version EOL constatera que son site a été changé pour une version plus récente et plus stable de PHP.