Passer au contenu principal
Maintenez vos activités pendant le COVID-19En savoir plus
Contactez-nous
Numéros de téléphone et heures
Centre d’aide

Explorez nos ressources d’aide en ligne

BlogAide

WordPress Aide

Nous avons fait de notre mieux afin de traduire cette page pour vous. La page en anglais est également disponible.

Corriger une erreur interne du serveur WordPress

Une erreur de serveur interne (ISE), également appelée erreur 500, est un message d'erreur générique qui apparaît lorsque votre site WordPress ne peut pas être affiché. Dans les anciennes versions de WordPress, un ISE peut également apparaître comme une page blanche vierge sans détails d'erreur. L'erreur peut se produire pour diverses raisons, mais elle est généralement due à un conflit avec WordPress, un plug-in, un thème ou l'un des fichiers de contrôle du site. Cela se produit le plus souvent après une mise à jour.

Trouver la cause d'un ISE, puis la résoudre est souvent une question d'essais et d'erreurs. Voici quelques-unes des façons dont vous pouvez trouver la cause de l'erreur avec des liens vers des articles qui vous guideront à travers chaque processus et décrivent comment y remédier.

Remarque: cet article couvre les méthodes de dépannage avancées, qui incluent la connexion à votre hébergement avec une application FTP, la modification ou la désactivation de fichiers et la modification de la base de données. Si vous ne souhaitez pas corriger cette erreur vous-même, notre équipe de support WordPress Premium peut le faire à votre place.

Avertissement: effectuez toujours une sauvegarde de votre site avant de dépanner ou d’apporter des modifications.

Désactivez votre fichier .htaccess

Un fichier .htaccess corrompu est l'une des causes les plus fréquentes d'un ISE. Le .htaccess est un fichier de contrôle que WordPress utilise pour communiquer avec le serveur. WordPress, les plug-ins et les thèmes apportent souvent des modifications à ce fichier, ce qui peut parfois endommager le fichier.

Lors du dépannage d'un ISE, commencez par désactiver votre fichier .htaccess , puis visitez votre site en mode de navigation privée ( Chrome / Firefox / Edge ). Si l’erreur a disparu, réinitialisez vos permaliens pour créer automatiquement un nouveau fichier .htaccess.

Remarque: le fichier .htaccess est masqué par défaut dans certaines applications de gestion de fichiers. Si vous utilisez cPanel ou FileZilla , veillez à activer l'option permettant d'afficher les fichiers cachés si vous ne voyez pas le fichier.

Augmentez vos limites de mémoire

Votre compte d'hébergement attribue une quantité définie de sa mémoire à l'exécution de PHP, ce qui est nécessaire au fonctionnement de votre site WordPress. En raison de la taille de votre site ou du nombre de plug-ins utilisés, le site peut nécessiter plus que la mémoire PHP par défaut.

Pour ce faire, connectez-vous à votre compte d'hébergement avec FTP et augmentez la limite de mémoire WordPress dans le fichier wp-config.php (si votre site n'est pas en hébergement WordPress, ignorez l'étape 1).

Si l'augmentation de la limite de mémoire WordPress n'a pas fonctionné, essayez d' augmenter la limite de mémoire PHP à 256 Mo ou 512 Mo.

Désactivez tous vos plug-ins

Les plug-ins WordPress peuvent provoquer un conflit entre eux, avec un thème actif ou avec votre version de WordPress, ce qui peut conduire à un ISE. Cela est plus probable après la mise à jour de WordPress, du thème actif ou de l'un de vos plug-ins.

Pour vérifier si un problème est causé par les plug-ins, dans le dossier wp-content , renommez le dossier plugins en plugins.renamed et visitez votre site en mode de navigation privée. S'il se charge correctement, le problème est dû à l'un de vos plug-ins. Si l’erreur persiste, quelque chose d’autre la cause.

Renommez le dossier contenant les plug-ins en plug- ins et poursuivez l’étude du problème. Si cela est dû à des plug-ins, commencez à désactiver les plug-ins individuels pour déterminer lequel est à l'origine de l'erreur. . -

Si vous souhaitez continuer à utiliser le plug-in problématique, téléchargez la dernière version du plug-in avec FTP , puis activez-le. Cela mettra à jour le plug-in. Si la mise à jour ne fonctionne pas, essayez ce qui suit:

  • Recherchez le plug-in dans le référentiel de plug-ins WordPress sur wordpress.org . Sur la page d'accueil de votre plug-in, sélectionnez Afficher le forum de support . Recherchez sur le forum une solution spécifique à votre problème.
  • Si vous avez acheté votre plug-in ailleurs, consultez la documentation fournie par le développeur du plug-in.

Re-uploader les fichiers de base WordPress

Remarque: Si votre site est en hébergement WordPress géré, ignorez cette section car les fichiers de base WordPress sont préinstallés avec le plan d'hébergement. Ils sont automatiquement mis à jour pour assurer la sécurité de votre site et vous ne pouvez pas les remplacer par FTP.

Dans certaines situations, vos fichiers de base WordPress peuvent être corrompus pendant une mise à jour, provoquant une erreur interne du serveur. Essayez de télécharger à nouveau les fichiers de base WordPress pour vous assurer qu'ils ne sont pas à l'origine du problème.

Téléchargez la même version de WordPress que vous utilisez actuellement à partir du référentiel WordPress , décompressez-la sur votre ordinateur local, connectez-vous à votre compte d'hébergement avec FTP et transférez (remplacez) les dossiers wp-admin et wp-includes.

Remarque: si vous ne savez pas quelle version de WordPress votre site utilise, vous pouvez archiver le fichier wp-version.php qui se trouve dans le dossier wp-includes .

Basculer vers un thème WordPress par défaut

Si les options ci-dessus n'ont pas permis de résoudre le problème, votre thème est peut-être à l'origine du conflit. Pour tester, vous pouvez utiliser l'un des thèmes WordPress par défaut , comme TwentyTwenty ou TwentyTwentyOne .

Remarque: si vous n’avez pas installé de thème WordPress par défaut, vous pouvez l’installer avec FTP , puis l’activer dans la base de données .

Si votre site se charge correctement après le passage au thème par défaut, vous pouvez mettre à jour votre thème normal vers la dernière version et l'activer.

Si la mise à jour du thème ne fonctionne pas, essayez ce qui suit:

  • Recherchez le thème dans le référentiel de thèmes WordPress sur wordpress.org . Sur la page d'accueil de votre thème, sélectionnez Afficher le forum de support technique . Recherchez sur le forum une solution spécifique à votre problème.
  • Si vous avez acheté votre thème ailleurs, consultez la documentation fournie par le développeur du thème.

En savoir plus